Create Launcher in Ubuntu 12.04 (Unity)

Just purcahsed PyCharm and enjoying using it thus far.

One problem I'm running into is on Ubuntu 12.04 (64-bit, just in case that matters) I can't create a launcher. I've tried creating one manually as well as using the option in the Tools menu in PyCharm, but no dice either way. The desktop file gets created in ~/.local/share/applications but when i click on the PyCharm launcher nothing happens. PyCharm works fine if I launch it from a terminal. (And I have tried logging out and even rebooting after creating the launcher, but that has no effect.)

I've also tried editing the desktop file and adding the window manager class explicitly but that doesn't have any effect either.

Any ideas? Thanks.
11 comments
Please do a following:
  • exit PyCharm and unlock it's icon from a launcher (if any)
  • start PyCharm from a command-line
  • invoke "Tools | Create Desktop Entry"
  • exit PyCharm
  • restart a session (*)
  • launch PyCharm from Dash
  • wait until it starts (a main window appears), then pin it to a launcher

(*) not always required but this way it's more reliable
0
Thanks – I've tried that a few times and it doesn't work. When I try to launch PyCharm from Dash nothing happens – no error or anything, it just acts like I didn't click it at all.

I'll try again in a bit and see if maybe 5th time's the charm, but that hasn't worked for me thus far. Are there any logs that would show what's happening when I click the link from Dash and nothing happens?

Thanks again.
0
I got this to work in 12.04 by right clicking the  ~/.local/share/applications/PyCharm.desktop file in nautilus, selecting "Properties", switching to the "Permissions" tab, and selecting "Allow executing file as program".  Everything is working fine now :)
0
Very nice – thanks! I'll give that a shot.

On Sun, Oct 14, 2012 at 3:08 PM, gaejake - PyCharm
--
Matthew Woodward
matt@mattwoodward.com
http://blog.mattwoodward.com
identi.ca / Twitter: @mpwoodward

Please do not send me proprietary file formats such as Word, PowerPoint,
etc. as attachments.
http://www.gnu.org/philosophy/no-word-attachments.html
0
Just in case you didn't get this solved, make sure you didn't run bin/pycharm.sh as sudo.
0
I wound up doing this:
http://blog.mattwoodward.com/2012/11/how-to-create-pycharm-launcher-on.html


On Sun, Mar 3, 2013 at 11:47 AM, tom dickin - PyCharm <
jetforum@jetbrains.com> wrote:

* PyCharm <http://forum.jetbrains.com/forum/PyCharm> * > * Create
Launcher in Ubuntu 12.04 (Unity)<http://forum.jetbrains.com/thread/PyCharm-1042>
* [ * linux <http://forum.jetbrains.com/tag/PyCharm-linux> * + * ubuntu<http://forum.jetbrains.com/tag/PyCharm-ubuntu>
* ] 2:47 pm<http://forum.jetbrains.com/thread/PyCharm-1042?message=PyCharm-1042-5>  tom
dickin <http://forum.jetbrains.com/user/tomdickin>

Just in case you didn't get this solved, make sure you didn't run
bin/pycharm.sh as sudo.

   Matt Woodward <http://forum.jetbrains.com/user/mpwoodward> @ 08/23/12<http://forum.jetbrains.com/thread/PyCharm-1042>

Just purcahsed PyCharm and enjoying using it thus far.

One problem I'm running into is on Ubuntu 12.04 (64-bit, just in case that
matters) I can't create a launcher. I've tried creating one manually as
well as using the option in the Tools menu in PyCharm, but no dice either
way. The desktop file gets created in ~/.local/share/applications but when
i click on the PyCharm launcher nothing happens. PyCharm works fine if I
launch it from a terminal. (And I have tried logging out and even rebooting
after creating the launcher, but that has no effect.)

I've also tried editing the desktop file and adding the window manager
class explicitly but that doesn't have any effect either.

Any ideas? Thanks.

  JetBrains Forum | Build #143 (Nov/16/2012 5:22PM) | Feedback<http://confluence.jetbrains.net/display/JETF/Feedback>




--
Matthew Woodward
matt@mattwoodward.com
http://blog.mattwoodward.com
identi.ca / Twitter: @mpwoodward

Please do not send me proprietary file formats such as Word, PowerPoint,
etc. as attachments.
http://www.gnu.org/philosophy/no-word-attachments.html
0
Ah okay, did you ever figure out exactly what it was about your setup/process that prevented pycharm from being able to do this automagically?
0
Nope, never did get that figured out unfortunately.


On Sun, Mar 3, 2013 at 12:30 PM, Tom Dickin - PyCharm <
jetforum@jetbrains.com> wrote:

* PyCharm <http://forum.jetbrains.com/forum/PyCharm> * > * Create
Launcher in Ubuntu 12.04 (Unity)<http://forum.jetbrains.com/thread/PyCharm-1042>
* [ * linux <http://forum.jetbrains.com/tag/PyCharm-linux> * + * ubuntu<http://forum.jetbrains.com/tag/PyCharm-ubuntu>
* ] 3:30 pm<http://forum.jetbrains.com/thread/PyCharm-1042?message=PyCharm-1042-7>  Tom
Dickin <http://forum.jetbrains.com/user/tomdickin>

Ah okay, did you ever figure out exactly what it was about your
setup/process that prevented pycharm from being able to do this
automagically?

   Matt Woodward <http://forum.jetbrains.com/user/mpwoodward> @ 08/23/12<http://forum.jetbrains.com/thread/PyCharm-1042>

Just purcahsed PyCharm and enjoying using it thus far.

One problem I'm running into is on Ubuntu 12.04 (64-bit, just in case that
matters) I can't create a launcher. I've tried creating one manually as
well as using the option in the Tools menu in PyCharm, but no dice either
way. The desktop file gets created in ~/.local/share/applications but when
i click on the PyCharm launcher nothing happens. PyCharm works fine if I
launch it from a terminal. (And I have tried logging out and even rebooting
after creating the launcher, but that has no effect.)

I've also tried editing the desktop file and adding the window manager
class explicitly but that doesn't have any effect either.

Any ideas? Thanks.

  JetBrains Forum | Build #143 (Nov/16/2012 5:22PM) | Feedback<http://confluence.jetbrains.net/display/JETF/Feedback>




--
Matthew Woodward
matt@mattwoodward.com
http://blog.mattwoodward.com
identi.ca / Twitter: @mpwoodward

Please do not send me proprietary file formats such as Word, PowerPoint,
etc. as attachments.
http://www.gnu.org/philosophy/no-word-attachments.html
0
You need to modify the pycharm.sh file (pycharm-<version>/bin/pycharm.sh)
and add your JAVA_HOME path
i.e.
JAVA_HOME="/home/username/java"

That worked for me... it depends on how you installed the Java JRE/JDK on your system.

Then launch from the desktop icon (search as people have said above) and pin to your bar.
0

I got it to work on my Ubuntu 12.04 64-bit machine by following Roman's instructions. Thanks Roman!

0

Hello Jeff,

I need your help !
I want to install linux os in my camera.

luan(dot)michel(dot)tran(at)gmail(dot)com

0

Please sign in to leave a comment.