Pycharm 2.6 crashing fairly often

I realise this is an early release, and has no guarantees of being stable but it has been crashing a lot and perhaps some useful information can be gained from my app logs.

It can be when I'm typing or when I'm debugging but it will just close with an apple error report left in its place

I recently wiped my mac and started with a clean install of 10.6.8, using pycharm since it seems pretty unstable (I never had this problem before the reformat)

please let me know if I can help

Cheers!

Paul
7 comments
Comment actions Permalink
So could you please attach a crash log? Normally native crashes are not caused by bugs in PyCharm, because it contains very little native code, but we'd like to have a look anyway.
0
Comment actions Permalink
Sure!- sorry I meant to attach them originally, here they are.
logs.zip (180KB)
0
Comment actions Permalink
This has been happening more and more often since I posted. I went back to 2.5.2 after a while but the issue is the same there.

It's now crashed maybe 6 or 7 times in the last few minutes, often it is crashing before the ide fully loads up. Its got to the point now where it's completely unusable :(

I've attached fresh logs, there should be another dozen or so crashes in there, in case there's any new clues

Archive.zip (230KB)
0
Comment actions Permalink
I see that you're running a fairly old Java version, 1.6.0_15. Isn't there a newer Java update that you can install on Mac OS X 10.6.8? If there is, it's very likely that it will resolve the problems you're seeing.
0
Comment actions Permalink
Ah thanks, I've updated it now, I think it may have fixed it- I'll let you know how it goes.

Almost all code completion and the like stopped working as well for some reason, possible something corrupted with all the crashing ( this happened since posting the last set of logs) I've no idea why, and can't seem to find a fix by searching.

Sorry to bother you again but any ideas? fresh logs attached, there's at least another 12MB since before so I guess that's from when the autocomplete/indexing stopped working
Archive 2.zip (493KB)
0
Comment actions Permalink
File | Invalidate Caches should help you with that. Also it's possible that you've run into http://youtrack.jetbrains.com/issue/PY-7451, for which a fix will be out Real Soon Now.
0
Comment actions Permalink
Good news!

I invalidated the cache yesterday and it didn't help, today I updated to 2.6.1 and still had the same problem, but after invalidating the cache again it has returned to full working order :D and I haven't had any more crashes since upgrading java, either

Thank you for your help!
0

Please sign in to leave a comment.