Switch spell checking to off

Hello,

I frequently check out my project from GitHub. On GitHub I have disable the syncing of the folder .idea/ in gitignore, because I'm afraid of the additional traffic this folder might cause.

The (small) problem: after checking out, the spell checker ist active again. I never ever want to spell check my code. Is there a way to completely deactivate spellchecking for AppCode on an application level?

Thanks in advance

Ray

5 comments
Comment actions Permalink

Yes, see File->Template Settings->Inspections->Project Default->Spelling.
This setting will be inherited by all new projects.

0
Comment actions Permalink

Thanks a lot for your response!

BTW: is there a documentation where I could have looked this up? On the docs page I didn't find one.

Thanks again.

0
Comment actions Permalink

Ray,

AppCode doesn't have a dedicated help yes; though, you can check IntelliJ IDEA documentation, since both products share the same platform:
http://www.jetbrains.com/idea/webhelp/getting-help.html

0
Comment actions Permalink

Hello,

unfortunately this doesn't work here. Every time I check out the project, the spell checking is active again.

Whtas the name of the file where this setting is stored? I will exclude it from gitignore and try again.

Thanks

Ray

0
Comment actions Permalink

Ray,
this is strange. Do you check out the project on the same computer?
Please note, that you should change 'Project Default' scheme, not 'Default'

0

Please sign in to leave a comment.