All built-in functions are unresolved - followed advice in other threads

My work laptop was upgraded to Mountain Lion (10.8) from Lion (10.7), and ever since, PyCharm has stopped recognizing builtins. The app runs fine, but the red squiggly lines are getting to me. :/

It's the same problem reported in these threads:

http://forum.jetbrains.com/thread/PyCharm-1062
http://forum.jetbrains.com/thread/PyCharm-291

but the advice in those threads doesn't work for me.

I'm on PyCharm 2.6.3, running Mac OS 10.8, and the interpreter is running Python 2.6.7.  When my laptop was upgraded, we migrated over to network users (active directory? something like that) so all the users and permissions changed. I restored PyCharm settings from a backup.

Here's what I've done:
1. Removed the interpreter from settings (we're using a virtualenv), rebuilt it and then set it as the default interpreter. It detects all the libraries and runs fine, but the red squigglies come back.
2. Confirmed my current user owns (and can read/write to):
~/Library/Preferences/PyCharm20
~/Library/Application\ Support/PyCharm20
/Applications/PyCharm.app

I'm sure it's something related to the install or permissions or something dumb like that. Any help is appreciated!
2 comments
Comment actions Permalink
Rachel, try "File | Invalidate Caches". Also try deleting, restarting PyCharm and then adding again the default interpreter.
0
Comment actions Permalink
Awesome, that worked! Thanks so much!

For other's reference - I ran invalidate caches (which did not work). Then I deleted and reinstalled Pycharm, deleted the interpreter, invalidated the caches, rebuilt the interpreter, and then re-added it. After Pycharm re-indexed everything, it now recognizes it.
0

Please sign in to leave a comment.