Disable vertical line indicating suggested line length limit?

In the python editor there is a vertical line at 120 columns, presumably to indicate a suggested maximum line length. (The line seems to be at different positions for at least some other file types.)

I would like to make this line disappear but have yet to find a method of doing so. I would appreciate information from anyone who can advise me.

Thanks!
5 comments
Comment actions Permalink

In PyCharm 2017 this has moved, but can still be done by:

Editor > Color Scheme > General. Then in the new control to the right, open Editor > Guides > Hard wrap guide, and uncheck the checkbox for "Foreground".

6
Comment actions Permalink
Settings | Editor | Colors and Fonts | General, select "Right margin", uncheck the checkbox for "Foreground".
2
Comment actions Permalink

Pycharm 2018

Goto File > Code Style > Hard Wrap at "120".

Change value: 120 to 200 or more.

Click Apply.

There you go.

2
Comment actions Permalink
Many thanks!
0
Comment actions Permalink

tools, preferences, editor, uncheck 'show vertical line after' 'x' characters.

0

Please sign in to leave a comment.