Cannot install 'distribute' package in project using vagrant

I created a new project and set up Vagrant according to the quickstart guide here: http://www.jetbrains.com/pycharm/quickstart/configuring_for_vm.html

Vagrant seems to setup fine and I can even run basic scripts via the remote interpreter, however the "Python Interpreters" settings pane shows no packages installed and no paths for the remote interpreter. Clicking the link that says "install 'distribute'" throws the following error:

Error occurred when installing package distribute-0.6.27.

The following command was executed:

\tmp\tmpCYNaulpycharm-management\distribute-0.6.27\setup.py install

The error output of the command:

Traceback (most recent call last):
  File "/home/vagrant/.pycharm_helpers/chdir_run.py", line 8, in <module>
    os.chdir(working_dir)
OSError: [Errno 2] No such file or directory: 'tmptmpCYNaulpycharm-managementdistribute-0.6.27'


I'm running Windows 7 and I've tried this with the default lucid32 Vagrant box as well as a more recent version. I've tried upgrading guest additions on both and still get this error. I'm using the latest PyCharm, Vagrant and VirtualBox.

Are there some path settings that I'm missing or something that's been left out of the documentation?

Please sign in to leave a comment.