Bug: caret jumping around when selecting + scrolling

I have had a recurrent bug in my PyCharm 2.7.2 editor (either editing Python or HTML or CSS, etc). This didn't happen when I used PyCharm 2.6, it started happening after I updated, but I don't remember exactly when it started (2.7? 2.7.1? 2.7.2?).

When I move the text caret (with keyboard arrows) and the canvas scrolls, sometimes the caret jumps to a position I wasn't expecting it to go. This only happens when the caret causes scrolling to happen. When no scroll happens, the caret goes where I want it to go.

This is best explained by examples. | is where the caret is. I have a file with some short lines and one line that is long enough to pass the canvas width.


long_line_that_exceeds_canvas_width()
foo.bar()
Xabc.efg()


If I hold the left arrow down, the caret goes here, as expected:


long_line_that_exceeds_canvas_width()
foo.bar()X
abc.efg()


If I keep on holding the left arrow, I get here, as expected:


long_line_that_exceeds_canvas_width()
Xfoo.bar()
abc.efg()


And then:


Xline_that_exceeds_canvas_width()
ar()
efg()


That is, the canvas scrolls to the right so that I can see the right end of the long line, BUT the caret strangely goes to the left of the canvas. What I expected to happen, and was working normally before some update, was this:


line_that_exceeds_canvas_width()X
ar()
efg()




This bug also happens when I'm trying to select text. A simple SHIFT+PAGE_DOWN should select the code from the previous caret position to the next (paged down) caret position. But it doesn't. Instead, the caret moves down one page, but the selection is canceled.

This also happens when I start like this:


Xlong_line_that_exceeds_canvas_width()


And I use SHIFT+END to select the whole line. But what happens is that the selection is canceled, and the caret moves where it shouldn't move.


Xline_that_exceeds_canvas_width()


I have tried tweaking the editor configurations, like Settings > Editor > Scrolling, neither "Prefer scrolling editor canvas to keep caret line  centered" nor "Prefer moving caret line to minimize editor scrolling" solved the problem.

Is there somehow I can configure PyCharm to work as intended, or is this really a bug? This is really annoying and affects my daily work.
1 comment
Nevermind, I uninstalled the IdeaVim plugin, and the problem was solved.
0

Please sign in to leave a comment.