Installing SciPy in a Virtual Environment Can't Find Fortran Compiler

Hi,

First of all, I'm pretty new at all this, so I might be completely missing something here...

Anyway, I want to use SciPy in a project I'm working on in PyCharm, and I'm using a Virtual Environment for the project.  I've installed gcc and gfortran, and have successfully installed NumPy, matplotlib, iPython, and a few other packages without any issues using PyCharm's package installer, but when I try to install SciPy, I run into the same error everytime, and I've tried a lot of different things to get it to work.

I'll paste the last few lines of the error I receive at the end of my post, but basically, it seems that when I try to install SciPy into my virtual env, it can't find my gfortran compiler.  Interestingly enough, when I try to install SciPy into my default/regular Python interpreter (sorry I'm not sure what to call it), it installs successfully.  I'm sure I'm missing something obvious here, but I can't seem to figure this out.  Any help would be amazing!!

Sorry for the messy error log, but I have a feeling the answer is somewhere here:

running build_clib

customize UnixCCompiler

customize UnixCCompiler using build_clib

customize Gnu95FCompiler

Could not locate executable gfortran

Could not locate executable f95

customize NAGFCompiler

customize AbsoftFCompiler

Could not locate executable f90

Could not locate executable f77

customize IBMFCompiler

Could not locate executable xlf90

Could not locate executable xlf

customize IntelFCompiler

Could not locate executable ifort

Could not locate executable ifc

customize GnuFCompiler

Could not locate executable g77

customize G95FCompiler

Could not locate executable g95

customize PGroupFCompiler

Could not locate executable pgfortran

don't know how to compile Fortran code on platform 'posix'

building 'dfftpack' library

error: library dfftpack has Fortran sources but no Fortran compiler found

----------------------------------------
Command /Users/Mindspyk/DataScience/bin/python -c "import setuptools;__file__='/private/var/folders/y1/plg2y71s23x_yvtsnwvx27540000gn/T/pycharm-packaging842489231709764069.tmp/scipy/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/y1/plg2y71s23x_yvtsnwvx27540000gn/T/pip-tM0SaV-record/install-record.txt --single-version-externally-managed --install-headers /Users/Mindspyk/DataScience/bin/../include/site/python2.7 failed with error code 1 in /private/var/folders/y1/plg2y71s23x_yvtsnwvx27540000gn/T/pycharm-packaging842489231709764069.tmp/scipy
Storing complete log in /Users/Mindspyk/.pip/pip.log
prettyPrint();

Please sign in to leave a comment.