PyCharm Not Detecting Installed Apps in Django

Whenever I add third-party django apps to my virtualenv, PyCharm does not "detect" them. The app is installed using requirements.txt and pip, is in my installed apps in and the app functions as expected, but PyCharm IDE doesn't detect the app when I try to import the app.....

Any ideas? Thanks
Hi Erve,

I tried to do the same and that worked for me with Markdown.

Could you please check that:
1. You have added the application you needed to the requirements.txt provided for this application (e.g. markdown>=2.3.1)
2. You ran pip from the catalog where your virtualenv is situated (You could check it in Settings->Project interpreter->Python interpreters)(e.g. C:\Users\user\Python2.7.5_Django)but not from the catalog of initial Python interpreter (e.g. C:\Python27)

Whether it does not work for you please provide the link to the application you want to use.
Thanks Ekaterina. I think the problem is actually more to do with the delay in PyCharm updating the interpreter's skeletons...? For example, after I reload the project (which is using a remote interpreter in Vagrant), the third party apps are found. SO, what would be useful is a way to force PyCharm to update the interpreter/skeletons....

I'm probably not using the correct terminology here, but I hope you understand what I mean!!

In short, PyCharm is detecting my third party apps, but only after some time or after closing and re-opening the project.

To reload the list of libraries on demand please try to reload a list of paths in a tab Path of Settings->Project Interpreter->Python interpreters->Your_python_interpreter_name.

Please sign in to leave a comment.