Fixed: SSH .git Repo key requires password shows "Nothing to Push"

When utilizing a git repo through PyCharm that has a password protected SSH key, the GUI will always tell me "Nothing to push" to the repo, instead of asking for the SSH key password, or alerting that one is required.

I do feel the "Nothing to push" dialog is useful in showing that it did not push changes, thus reminding me to manually do it via command line, but it is misleading.

Have others experienced this?

I should note it is not an option to remove the password on the SSH key.
Comment actions Permalink
I'm not sure that this is connected with the SSH key passphrase.
Are you pushing a new branch to the server, or your branch is already tracking some remote branch?
Try to select "Push to alternative branch" checkbox at the bottom of the Push dialog and see if that helps.
Comment actions Permalink
I am already tracking the remote branch on the server.  I tried seeing if your advice would have an effect but it doesn't.

What is very unusual is from another dialog it did ask me for the password for the git repo.  I believe at this point I should create a set of reproducible steps for a bug report.  Thanks for your input.
Comment actions Permalink
I have to retract.  I tried it again, and it appears that by default I wasn't pushing to the specified host.

Thanks Kirill, you are correct!

Please sign in to leave a comment.