Custom code commenting issue. (Pyramid Chameleon Templating)

I am using the windows pycharm 2.7 version with Pyramid chameleon templating.  Pycharm's standard line and block code comments use <!–   –> to comment out the html code.  However, although chameleon acknowledges the line comment code it still evaluates what's inside of the comments.  If you have something in your commented code that chameleon does not like you get a templating error.

Chameleon does offer a work around for this by using <!–?  –> to fully comment out chameleon html templating code.  I have tried using Pycharm custom comment settings to no avail.  There is just not enough flexibility in the settings.

Is there a work around for this or can you add this functionality in a next revision of pycharm? Ideas?
5 comments
Hi fatfantasma,

here is a similar issue in our tracker – http://youtrack.jetbrains.com/issue/PY-10458
Please, feel free to vote it and get notified once it's fixed
0
Hi Ekaterina,
Yes, that is the exact problem.  I have added a comment to Youtrack issue.  I hope this gets implemented ASAP.  It's very frustrating not being able to comment out chameleon PT files.
0
After switching to Pycharm 3.0 EAD I am no longer able to comment out html or xhtml code (ctrl-/ or ctrl-shift-/).  I also not able to edit the settings|file types for xhtml and xml and modify their code commenting settings.
0
http://youtrack.jetbrains.com/issue/PY-10458

Related to this, and:
PY-10458 Chameleon: comment with block comment does nothing inside html ad pt files

I'd really like the option to have chameleon comments use the
! (bang) instead of (?) question mark, like this:

<!--!   –>  

Is it possible for a user to configure this behavior?

Thanks!
   -kb
0
The <!--?  –> truly comments out the html chameleon code.  I'm interested to know the reason or benefit of using <!–! ->.  Just curious.
0

Please sign in to leave a comment.