How to enable meta key?

There are all sorts of meta-something shortcuts in PyCharm, but neither the 'alt' or 'windows' key on my keyboard seems to be 'meta'.

How can I make 'alt' on my keyboard act as the 'meta' key?
9 comments
Comment actions Permalink
Please change your keymap to default for XWin in File->Settings->Keymap. You will have Windows buttons in your shortcuts after that.
You could change any shortcut there as well.
0
Comment actions Permalink
That just changes the key mappings. My problem is that I want to have key mappings that are 'meta'-some character –> some command, but no key on my keyboard appears to be generating the 'meta' key.
0
Comment actions Permalink
Which operating system do you use?
0
Comment actions Permalink
Ubuntu 12.04 with Gnome 2 (gnome-fallback).
0
Comment actions Permalink
Please try to change your system settings:  System -> Preferences -> Keyboard -> Layout -> Options -> Alt/Win key behavior. Choose there "Meta is mapped to left Win".
Please tell whether it helps.
0
Comment actions Permalink
That worked!

Is there any way to have meta on alt instead of win? I tried "alt and meta are on alt keys", to no avail.
0
Comment actions Permalink
If you run PyCharm in a Gnome terminal it may be capturing your Alt key to open the GUI menu (File, Edit, ...). You can change this behaviour by selecting Edit -> Keyboard Shortcuts and unchecking "Enable menu access keys ...".
0
Comment actions Permalink

Do you have similar option in Ubuntu 18.04?

0
Comment actions Permalink

@PZwolin Search for the Tweaks!

0

Please sign in to leave a comment.