idea.max.vcs.loaded.size.kb Doesn't Seem to Work

Answered
I would like to do a git diff on a SQL create script that is 52Mb but when I try to do it PyCharm gives the error:

Can not show contents of 'xyz.sql'.
File size is bigger than 20.0Mb.
You can relax this restriction by increasing idea.max.vcs.loaded.size.kb property in idea.properties file.


I have copied the idea.properties file from /Applications/PyCharm.app/bin to ~/Library/Preferences/PyCharm30 then added the line

idea.max.vcs.loaded.size.kb=262144

to the bottom, restarted PyCharm, and still get the same message as above.

Is there something I am doing wrong?
4 comments
Comment actions Permalink

Same question in 2018 - I'd love to be able to run a diff on a "large" file but changing the setting specified has no effect. What do I have to do to increase this limit for PyCharm?

 

Thanks!

0
Comment actions Permalink

Adding the following to the idea.properties (the best way is to invoke Help - Edit Custom Properties) works:

idea.max.vcs.loaded.size.kb=40000

any number should work.

A restart is required to reload the proeprties.

-1
Comment actions Permalink

It is not working in PHPStorm he tells me something about an "ultimate" Edition? Why this is not in standard? imho this is a bug.

I need this in PHPStorm for large files. Please integrate it.

0
Comment actions Permalink

> It is not working in PHPStorm he tells me something about an "ultimate" Edition?

Could you please attach a screenshot of this?

 

0

Please sign in to leave a comment.