PyCharm install help Windows 7

I successfully installed PyCharm but there are issues when I try to compile a program it gives the following error:

"C:\Python33\python.exe: can't open file '/Python Console': [Errno 2] No such file or directory"

I can't find "Python Console" anywhere on the drive and Python 3.3 is installed.

How do I fix this?
4 comments
Comment actions Permalink
When you say compile the program, do you mean run it? Check that your interpreter is correctly defined and set as the project interpreter under File -> Settings -> Project Interpreter. Also go to Run -> Edit Configurations and make sure a Python run configuration is defined with your chosen interpreter. Maybe post a screenshot of your run configuration.
0
Comment actions Permalink
Preston, you are correct... The problem happens when I try to run the program. Here's what I have done so far:
Uninstalled Python33 and Pycharm 3.02. Did a fresh download of each program from the Python and Pycharm websites. Installed Python33 first and then Pycharm. There were no errors reported on either install. Set the interpreter to c:/python33/python33.exe

The first problem is Pycharm cant find it's tips file. When I run the 2-line program, the error is generated. The attached pictures show the program, run error, and tips error.

I am using the Community version of Pycharm and windows 7

Any other thoughts on how to fix this?

Tip.JPG

Interpreter.JPG

error.JPG
0
Comment actions Permalink
You didn't post a screenshot of your Run configuration, which is most likely where the problem lies. I notice that your run configuration is called "Python Console", and it's trying to execute a Python script called "Python Console" and failing (whereas your script is called "Test"). I think part of the problem might be that your script is called "Test" instead of "Test.py". Try adding the .py extension to the file. Also delete and re-create your Python run configuration, and if it's still not working, post a screenshot of that.

I don't know about why the tips would be missing, I haven't seen that. It does seem to suggest maybe an incomplete or failed install.
0
Comment actions Permalink
Well, I'm back at trying to run my first program.  I changed the run script as described above and now when I run the program, it no longer gets an error. Now I need to find out where the output of the Print command is going because I don't see it.
0

Please sign in to leave a comment.