How to disable Double-Shift for Search Everywhere

Hi,

I installed PyCharm 3.1 today.
Using the new version, I've noticed that Search Everywhere floating window often appeared suddenly when writing codes on editor, and it took away keyboard focus from the editor. It's annoying...

So I would like to disable Doublie-Shift for Search Everywhere. But I don't know how to do it.
4 comments
Comment actions Permalink
Hi there,

I do not think that you can actually turn it off.

But you can assign better/more suitable shortcut for it so that Double Shift will NOT trigger it.

Settings | Keymap – type "Everywhere" in search box.

If you assign some complex and difficult to press shortcut, there is extremely little chance that you will press it accidentally.
0
Comment actions Permalink
I mapped it to Command S/Strg S. I need search everywhere a lot more often that Save all (which I probably have never used before).
0
Comment actions Permalink

I modified the shortcut keys, but it will pop up the window.

I use phpstorm 2017.1.3 macOs

1
Comment actions Permalink

@Persi

Looks like regression -- follow this ticket for details/updates: https://youtrack.jetbrains.com/issue/IDEA-163555

0

Please sign in to leave a comment.