Can't run nosetests by default when django support is enabled

After upgrading to pycharm 3.1 or 3.1.1 when I attempt to run the tests within a file or directory in my project structure, pycharm is creating a django test runner. However my projects default test runner has been set to the nosetests test runner. If I disable django support within pycharm the nosetests runner is used.

Is there a way to make pycharm respect the test runner when the default has been set or is this a regression in pycharm 3.1?
1 comment
Comment actions Permalink
I am having the exact same issue, even in Pycharm professional 4.05
0

Please sign in to leave a comment.