Manually set encoding does not work

When I manually set encoding for specific file in File|Settings|File Encodings to ISO-8859-2 and open this file, characters are not being displayed correctly and in the status bar there's still UTF-8 being displayed. When I click 'UTF-8' from status bar and change encoding to ISO-8859-2 and then choose Reload nothing happens - characters are still not displayed correctly and encoding in the status bar is still UTF-8.

Pycharm 3.1.1
Windows XP SP3
6 comments
Comment actions Permalink
Hi there,

"Settings | File Encodings" – do you have "Autodetect UTF-encoded files" checked?

If yes – uncheck it (IDE restart may be required to see this change actually working – at least it was in the past, possibly fixed by now).
0
Comment actions Permalink
Thanks for info. After turning autodetect off, there's proper encoding in the status bar (set for this specific file in settings) but display is still wrong. File looks ok when viewed in Notepad++ with the same encoding set (ISO-8859-2).
0
Comment actions Permalink
Please attach your original file + screenshot of how it looks in your IDE (whole IDE screen)
0
Comment actions Permalink
Strange, it seems to work now... I'm sorry for trouble and thanks for help.
0
Comment actions Permalink


"Settings | File Encodings" – do you have "Autodetect UTF-encoded files" checked?

If yes – uncheck it (IDE restart may be required to see this change actually working – at least it was in the past, possibly fixed by now)."

 

I did not find this setting.

 

Solved the issue by setting global encoding as System Default.

0
Comment actions Permalink

@Roar Gjovaag

>I did not find this setting.

Because it was removed few years ago...

0

Please sign in to leave a comment.