X11 Forwarding

I am part of an organization with multiple pro licenses.

We'd like to use Pycharm to edit on windows machines, but execute Selenium scripts using a remote virtualenv interpreter on Linux boxes. Is it possible to do X11 forwarding with Pycharm so that we don't have to also have an SSH client running at the same time?
8 comments
Comment actions Permalink
I haven't seen a suitable configuration option for this in PyCharm. But if it uses the system ssh command to connect to the remote host, you could try enabling X11 forwarding globally in /etc/ssh/ssh_config (or whereever that is on your system). Just an idea...
0
Comment actions Permalink
Yeah this works on a mac, because you can set SSH X11 forwarding globally. Is it possible on a windows machine?

Pycharm folks, it would be a great feature if you could add this to the run config dialog.
0
Comment actions Permalink
Sorry. No idea.
0
Comment actions Permalink
I was able to get this working by adding the DISPLAY environment variable to the run configuration like so:

DISPLAY=localhost:102

Not sure if that will be exactly the same for eveyone.
0
Comment actions Permalink
I've been doing this using PyCharm 3.1.1 on a linux (F20) system running in just standard text mode by ssh x forwarding to both Windows 7 and OSX 10.9.2 with no problems at all.  I didn't have to do anything but use the -X of ssh to have it forward to my other systems.  You need to have an x server running on those Windows and OSX environments.  I use cygwin's x server on Windows and the OSX x server app on OSX.
0
Comment actions Permalink
I would like to know this too. Piggybacking on an existing ssh -X connection works if I set the DISPLAY variable. Setting ForwardX11(Trusted) globally doesn't help however.

@JetBrains: It would be great if the vagrant remote interpreter respected the config.ssh.forward_x11 setting from the Vagrantfile.
0
Comment actions Permalink

I have questions about this too : None of the proposed solutions have worked for me. 

How do I PyCharm to use -X when doing the ssh so that the matplotlib diagram appears on my mac? 

0
Comment actions Permalink

Ok, I found I needed to do two things to get it working well enough for me :

(1) Set DISPLAY = localhost:10.0 in the Environment Variables under Build, Execution, Deployment -> Python Console
(2) Right after import matplotlib
matplotlib.use('Qt5Agg')

0

Please sign in to leave a comment.