Setting $TERM for debugger terminal

I'm running PyCharm 3.1.3 on CentOS 6.5 and I'm having a bit of a problem.

Whenever I run any command with os.system('command'), I get the error "'emacs': unknown terminal type." The command still executes, and I still see the output, but the error is a bit annoying.

This error only appears in the debugger terminal, and not the regular terminal. I have run "echo $TERM" in a few places, and this is the result:

"echo $TERM" in gnome-terminal (regular Linux terminal) - xterm
os.system("echo $TERM") in python interpreter directly (without PyCharm) - xterm
"echo $TERM" in PyCharm's regular terminal - xterm
os.system("echo $TERM") in a program running through PyCharm's regular terminal - xterm
os.system("echo $TERM") in a program running through PyCharm's debugger terminal - emacs

I've looked in PyCharm's settings, but can't seem to find any place to set TERM=xterm for the debugger. I have a few workarounds for hiding the errors, but not a permanent solution. Am I missing something?
1 comment

I'm having a similar problem in Ubuntu, when clicking the debug option next to the run button I get the following error in the Console:

pydev debugger: process 13699 is connecting

Connected to pydev debugger (build 145.1504)
'emacs': unknown terminal type.

My TERM also = xterm.

If you managed to find a solution to the problem I'd be grateful if you would share it.

 

Thanks,

 

Lee.

0

Please sign in to leave a comment.