installing new packages in virtualenv with Pycharm invisible outside pycharm

I have pycharm 3.4.

I created a virtualenv via command line.  I installed 3 packages with the venv pip via command line. These appear in python run from command line.

I then installed many packages using the project interpreter dialog of Pycharm.

These packages are not visible via command line when I run python.

python code that uses the packages runs when running from Pycharm.  When running the same code from the command line, all the imports for the packages in the vent fail.

This appears to be some kind of deep path problem on my machine (OS X mavericks).  But, the path appears to point to the vent and list it FIRST, so in theory it should be first in line.  But it is being ignored.  Which python and which pip do not find the python and pip in the vent.

I am at a loss as to what is wrong.  Hundreds of Google results have not pointed to any solution.

Here is the path variable:
/Users/lewislevin/Dropbox/flaskprojects/venv/bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/Library/Frameworks/Python.framework/Versions/Current://usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin

Any ideas?
2 comments
Solved–I guess.

When something inexplicable happens and reboot doesn't work–then reinstall.

Reinstalled virtualenv with virtualenvwrapper.  Re-piped the projects.  Pycharm is happy.  Cmdline python is happy.

What happened?  Who knows...    Some auto-corruption in virtualenv.
0
I remain a bit suspicious that mixing and matching virtualenv codline tools and Pycharm's management of the virtualenv might not be safe.
0

Please sign in to leave a comment.