PyCharm ignoring LD_LIBRARY_PATH from .bashrc

When PyCharm is launched from the Start Menu or the Panel Launcher in Linux Mint 17 the LD_LIBRARY_PATH environment variable which I've set in the .bashrc file is ignored.

os.environ['LD_LIBRARY_PATH'] only shows the project directory.

However, if I launch PyCharm from the terminal everything is OK.

Does anyone know what is causing this?


EDIT: I would just like to add that adding the line

source ${HOME}/.bashrc

to the launcher script pycharm.sh does not help.
3 comments
Comment actions Permalink
.bashrc is only read for interactive shells.  http://stackoverflow.com/questions/415403/whats-the-difference-between-bashrc-bash-profile-and-environment

You might want to put your LD_LIBRARY_PATH setting in .bash_profile then it will be applied when you log in.
0
Comment actions Permalink
Thanks for help, but this is does not work. It appears that there is no way to set up LD_LIBRARY_PATH for desktop environment without editing contents of /etc/ld.so.conf.d

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/366728
0
Comment actions Permalink
In that case you might write your own small script that sets LD_LIBRARY_PATH and then launches PyCharm, then change the Start Menu link to point to your script.
0

Please sign in to leave a comment.