Module flask not found

Hi,

I running the demo version of Pycharm 3.4.

I set up a flask site from scratch using the new project dialog box and with a new virtualenv using python 2.7.5
Everything worked fine.

I build the site, added some static, template files...
Every worked fine.

I installed the plug-in Frozen-Flask, edited some code and pycharm refuse to run the app anymore.

The debugger tells:
   
    line 1, in <module>
        """Append module search paths for third-party packages to sys.path.
    ImportError: No module named flask

with line 1 being:
   
    from flask import Flask

I remove any instances of frozen-flask. No luck.

I re-created a new virtualenv. No luck.

Next step, i created an empty flask project, with or without virtualenv, and it works. But if I copy my previous app in this new project (even without any frozen flask reference), it returns the same error message.

During all these steps, running the app with the terminal worked without any problem.

Can you help me understanding this bug/error?

Thanks
1 comment
Comment actions Permalink
How did you import the library in the first place?
0

Please sign in to leave a comment.