Installed font not visible (anymore) in Pycharm (SOLVED)

Hello,
I started using Pycharm CE on OS X. I installed the font Source Code Pro using Font Book, and started using it in Pycharm. Everything was working smoothly.

Today I decided to change the size of the font, going from 14 to 12 and the display became messed up. Characters overlapping, etc... I restarted Pycharm, and since then, Source Code Pro doesnt appear in the monospaced fonts anymore. I can still choose other fonts like Menlo and then everything works as expected. I can choose Source Code Pro in the "non-monospaced" fonts, but then the display is messed up, with characters being replaced by squares containing "A".

The font Source Code Pro is usable in other programs such as iTerm2 or Libre-Office.

Do you have any clues about what my problem may be?

edit: it seems to be related to italic/bold . Words not in italic/bold display fine.

edit2: SOLVED. I deleted all my schemes, and then created a new one, using Source Code Pro even if not listed in the monospaced fonts. The display got buggy with bad spacing for the keywords. But after a restart of Pycharm, the spacing was ok again.

Please sign in to leave a comment.