<no subject>

I opened up PyCharm, expecting to see my code in english, but my code is now in a foreign language I do not recognize. When I type in the PyCharm editor, it comes out in a foreign language but if I type in a firefox, for example, it types in english.

The settings in PyCharm are still in english but I cannot find how to switch the editor back to english. Even the line numbers are in a foreign language. I tried pulling a github repo (which is still in english on github) and it says 'All files are up-to-date'. I tried re-installing PyCharm and in the uninstall deleted all settings and plug-ins. When I re-installed it was the same foreign language inside the editor.

Any help would be greatly appreciated, I love PyCharm and don't want to switch IDE's over something so trivial!!! It must be some simple setting I am missing so far.

Thanks.

EDIT - I got PyCharm back to english in the editor. I uninstalled then reinstalled but the problem persisted. I then assumed there were some settings left over that were causing the issue. I'm on Windows Vista, so I found the .PyCharm40 folder in my User folder and deleted it. I then reinstalled and it works fine now, back to english!

I'm still curious about how I managed to mess up a setting like that, so I will leave this question up on the forum. Not urgent since I have a work-around if it happens again.

Please sign in to leave a comment.