PyCharm Education Edition Course Creator: Running task tests fails with "Error running test: Executable is not specified"

Hi,

I'm working on a course for the competition and am running into a very annoying error!

My task is named "helloworld". Using the green arrow button in the answer file, "run 'helloworld.answer'" works just fine. However, "run tests from 'helloworld.answer'" fails with the message: "Error running test: Executable is not specified". This worked earlier; I don't know what went wrong and can't seem to fix it!

I have checked that I have a project interpreter defined. I also defined a default interpreter. I tried using the system Python 2.7, reinstalling a new Python 2.7, and even reinstalling PyCharm Educational Edition.

Please help!

OSX 10.8
PyCharm Educational Edition 1.0.1
1 comment
Comment actions Permalink
Hi,

the problem seems to be weird. Could you please send the link to the project or the project itself?  We'll try to figure out what went wrong.

  • Dmitry
PyCharm Product Manager
0

Please sign in to leave a comment.