Package 'flask_util_js' is not listed in project requirements

Hello,

I'm using PyCharm Community Edition 4.0.5.

I'm developing a web application which uses Flask, and I'm using the flask_util_js package (https://github.com/dantezhu/flask_util_js). When I use this package in PyCharm, the IDE always warns me that this package is not in the requirements.txt, even though it is.

source:
from flask_util_js import FlaskUtilJs

requirements.txt:
flask-util-js==0.2.21

My assumption is that this might something to do with the name of the package using dashes. Is there any way to correct this without disabling the warning system?
1 comment
Comment actions Permalink
Hello Andrew,

Tell me please do you have any problem with other packages from requirements.txt or only with flask_util_js package?
Please, check the issue with Pycharm 4.5 RC: https://confluence.jetbrains.com/display/PYH/JetBrains+PyCharm+Preview+(EAP). If the problem is still there please attach your requirements.txt file.
0

Please sign in to leave a comment.