Can't run Django tests after upgrading to 4.5.x

After upgrading to 4.5, I wasn't be able to run tests. This is the error I'm getting:

ssh://vagrant@ -u /home/vagrant/.pycharm_helpers/pycharm/ test properties.tests.cases /vagrant/conjuntos
Testing started at 1:42 PM ...
Traceback (most recent call last):
  File "/home/vagrant/.pycharm_helpers/pycharm/", line 129, in <module>
  File "/home/vagrant/.pycharm_helpers/pycharm/", line 104, in execute
  File "/vagrant/venv/lib/python3.4/site-packages/django/core/management/commands/", line 50, in run_from_argv
    super(Command, self).run_from_argv(argv)
  File "/vagrant/venv/lib/python3.4/site-packages/django/core/management/", line 288, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/vagrant/venv/lib/python3.4/site-packages/django/core/management/commands/", line 71, in execute
    super(Command, self).execute(*args, **options)
  File "/vagrant/venv/lib/python3.4/site-packages/django/core/management/", line 338, in execute
    output = self.handle(*args, **options)
  File "/home/vagrant/.pycharm_helpers/pycharm/", line 91, in handle
    failures = TestRunner(test_labels, verbosity=verbosity, interactive=interactive, failfast=failfast, keepdb='--keepdb' in sys.argv)
  File "/home/vagrant/.pycharm_helpers/pycharm/", line 238, in run_tests
    extra_tests=extra_tests, **options)
  File "/home/vagrant/.pycharm_helpers/pycharm/", line 138, in run_tests
    return super(DjangoTeamcityTestRunner, self).run_tests(test_labels, extra_tests, **kwargs)
  File "/vagrant/venv/lib/python3.4/site-packages/django/test/", line 146, in run_tests
    suite = self.build_suite(test_labels, extra_tests)
  File "/home/vagrant/.pycharm_helpers/pycharm/", line 102, in build_suite
    suite = super(DjangoTeamcityTestRunner, self).build_suite(*args, **kwargs)
  File "/vagrant/venv/lib/python3.4/site-packages/django/test/", line 66, in build_suite
    tests = self.test_loader.loadTestsFromName(label)
  File "/usr/lib/python3.4/unittest/", line 114, in loadTestsFromName
    parent, obj = obj, getattr(obj, part)
AttributeError: 'module' object has no attribute 'cases'

Process finished with exit code 1
Empty test suite.

This is my project structure:

This is how I define the test:

This is how I define the interpreter:

This is my tests structure:

I have a configuration for runserver and works perfectly. Also Python Console works perfect. It worked before upgrading. I tried to remove .idea directory, cache, logs and preferences but nothing. Any idea how to solve this problem?

Please sign in to leave a comment.