Instance variables missing in debugger window

I'm debugging a class, and I need to see the values of the instance variables, but the debugger doesn't show them. The Variables pane has an entry for the instance of the class ("self"), but when I click the plus-sign icon to expand it, the icon disappears; the instance variables do not appear.

I can display the individual instance variables' values in the Evaluate Expression window, but that's a very inefficient technique. How can I make the debugger display these variables along with the locals?
9 comments
Hi! The instance variables should appear after clicking on icon, if they are not begins and ends with two underscores. Please provide a code of the class which reproduces the issue.
Also you can add desired instance variables to the Watches, and they will be displayed while debugger suspended.
0

I’m attaching a project that demonstrates the problem. I’m running it in PyCharm CE 4.5.1 under Windows 7 Professional.

I set a breakpoint at line 8 and ran the program in debug mode. When it stopped, the debugger’s Variables window showed the variables in the current scope. After I expanded self, I had this:

[+] a = {list} ['1','2','3','4']
[+] b = {list} ['1','2','3','4']
[+] kg = {function{ <function <lambda> at 0x…>
[-] self = {ComboList} []
    __len__ = (int) 0

The expansion of self should include kgKey, aKeys, and bKeys, but it does not.
0
Sorry, I can't see your project. Please report an issue to our tracker https://youtrack.jetbrains.com/issues/PY, attach a project and we will discuss it there.
0

instance_variables.zip (5.1KB)

I'm attaching the zip file again.

I don't have time to mess with the issue tracker, although I hope you'll arrange to have the problem corrected. The problem is the way your web site handles attachments. When an attachment is added it's represented by link below the text box (which makes sense) and a markdown command in the text box (which does not).

The markdown command looks like a random bit of junk. When I deleted it the link to the attachment remained, but the site silently discarded the attachment. Contemporary standards of forum design require something better than this.
0
Ok, now I understand the problem. There is a similar issue in our tracker: PY-9894
You can vote for it or monitor its status. Thank you for your feedback, stay tuned!
0
Thank you for clarifying that. I'm having problems with the voting process, though.

I didn't see a Vote button when I displayed PY-9894, and the log-in page didn't accept my forum credentials. I logged in as a guest but still didn't see a Vote button, so I tried to create a JetBrains account.

The first time I clicked the Confirm button in the "complete your registration" email, I thought my request was honored; I may have been mistaken, because I didn't read the response carefully. The bug tracker would not let me log in to the account I had created, so I clicked Confirm again and got a screen that said I couldn't create an account because I have no licenses. That's true; I'm using PyCharm Community Edition, as I said in my 25 June post.

Could you clarify what is happening here, please? If JetBrains has decided to let only licensed users access the bug tracker, I can't complain about that – but I think it's contrary to your own interest, because it narrows the user base who can report bugs.

I may also observe that effective technical organizations don't need to let their users vote on bugs, because it fixes them too promptly for votes to matter. It's not my place as a Community Edition user to criticize service levels, but if the bug system is only accessible to licensed users, this observation applies with some force.
0
Our tracker is opened for all users including Community Edition users. After registration you can start following the issue to receive automatic notifications from YouTrack when the issue is updated (status changes, new comments appear, etc).

If you use Community Edition you really have no licences and the site inform you about that on the page "Licenses". But it doesn't mean that your JetBrains account wasn't created. After registration you can log into YouTrack with your credentials and start using PyCharm issue tracker.
0
I tried again and was able to log in. Apparently the system just took a while to process my registration after I confirmed it.

However, the bug tracker now lists this bug as fixed. I don't know whether its status has changed since yesterday, or is displayed differently when a user is logged in. In any case, it won't allow me to vote.

Is the problem fixed in the latest release of PyCharm (v4.5.1)? If so, I'll install it and consider the problem resolved. If not, this is another unexplained mystery.
0
Yes, during our conversation the bug was fixed. The fix will appear in the next PyCharm update. The number of the version will appear in the field "Fix versions".
0

Please sign in to leave a comment.