Trying to set CLion to start with .c file and correct CMAKE at start

Answered

Hi all,

I'm just starting out with prgramming C and I'm trying to get to grips with CLion as my chosen IDE.

Can anyone tell me what settings I need to change to make CLion open a .c file and the correct CMAKE parameters for C instead of C++ by default?

Thanks!

2 comments
Comment actions Permalink

Hi!

Now CLion supports automatic creation of C++ projects only, but you can choose the preferred C/C++ source/header files extensions via File | Settings | Editor | Code Style | C/C++ | New File Extensions. You can find out more details in CLion web help: https://www.jetbrains.com/clion/help/code-style-c-c.html. As for the CMakeLists.txt you should change extension of main.cpp in set command manually.

Also we have a feature request about C project creation in the tracker:
https://youtrack.jetbrains.com/issue/CPP-860
Feel free to comment or upvote.
0
Comment actions Permalink

We've added C project template in CLion 2016.3.2 EAP. Please, read more details in our blog: https://blog.jetbrains.com/clion/2016/12/clion-2016-3-2-eap/#prj_templates. Your feedback is more than welcome!

1

Please sign in to leave a comment.