Can't run a simple program :(

Hi all
I'm VERY new to CLion so please be gentle :)
I took a project I did for a programming course I'm taking, I managed to build it, but when I tried to run it the CLion just freezes. I tried to run it in debug mode, but no success there either - it waits for a few seconds and then I recieve a message: "session timed out".

I thought the problem might be in my program, so I wrote a simple "Hello World" program - still no success.

few technical specs that might help:
I use CLion 1.2.1 (Newest version).
For my toolchains I use TDM-GCC compiler (downloaded from here: - I actually do not use the newest version - I use version 4.9.2-3 instead -  because I wanted the GDB to be 7.8 so Clion supports it).

My computer runs windows 10 (64 bit), intel core i5-4210, 8 GB RAM (for what it's worth...)

hope you could help me.
thanks in advance..


I have a similar problem, though I use msys2 (which is similar to what you have) on Windows 10. Please take a look: to see if this is what you experiencing. If this is your issue, then chances are this bug will not be fixed soon (as it is there for months now). I personally had to switch to codelite (it has convinient quick debug option there) for debugging and use clion for edit and build.   


hi, I solved to problem - I'm using avast anti-virus. all I had to do is uncheking "Deep Scan" option in the avast options menu. thanks anyway :)


Did you set up the configuration of your run or build in the right way?
try to edit configuration,choose a proper Executable
VIEW->TOOLBAR and you can see some tools appear,including a BUILD button,a RUN button and a DEBUG button.
between  the BUILD and the RUN button,there is an optional bar,click it and choose edit configuration,then choose a proper EXECUTABLE.
I was too trying HELLOWORLD program in this IDE for the first time but failed,I finally got it through maybe this can help you.


Please sign in to leave a comment.