Build menu option grayed out


I seem to have forgotten something related to install, since I cannot build anything in CLion currently, build menu options are greyed out. Toolchain settings look like this:
clion toolchains.png
Any help appreciated


Hi Isak.

Could you please attach the screenshot with greyed-out settings?


Its the actual build menu, implying that there is some setting somewhere that i have missed? I have had CLion working fine before in a previous install of windows, but I guess I must have done something differently this time around.

clion build menu.png


Please select Run or Edit Configurations and choose the target. I suppose that after that everything will be ok.


Like here? Only option is all targets,selecting it and hitting apply does not enable build menu

clion target.png


Could you please describe how you created your project? Also please attach your CmakeLists.txt.


Well, this is somewhat strange but now it works. It might have been my naming the project "test". This apparently is not allowed, or so it informs me now.

Thank you very much for your help


TL;DR : Try deleting the .idea directory and reopening your project.

I had a similar problem, I had a test cmake project that I hadn't given a name to using the project() command.

Turns out on Linux that wasn't a problem but on OSX, I opened the project in CLion as usual, then cmake couldn't finish due to some cryptic error that was caused by the project not having a name.

I added the name, everything worked fine but the .idea directory must have contained some stains from the un-named project: Everything in the build menu was greyed out excepth the "build project" option.

I deleted .idea and re-opened the project and the options came back.


I still face this issue. Every time I am deleting the .idea and trying to build. Anything I need to update?


I came across this issue in 2022. I was running on Linux and tried starting CLion from a different, remote terminal while it was still running on a some other remote connection. (I had to switch locations) I ran --help to see command line options and it tried starting a project called "--help". I think there were a few other missteps on my part. Bottom line, I finally got the original project up, but the CMake item was not at the bottom of the screen and the Build menu items were all greyed out.

I quit CLion, removed the .idea completely and restarted. Lo and behold, everything came back up and t was seeing the CMake project again. Thanks Philippe from > 3years ago!


Please sign in to leave a comment.