Special character in path messing up gcc command

Hi,

I'm having some trouble with CLion, more precisely, since my name is Dániel and Windows copies the name as is from Microsoft's servers, there is a special character in my user folder path making it Dániel in the gcc command.

Any idea where CLion takes the path from so I can change it? Or is it simply some internal encoding?

1 comment
Comment actions Permalink
Hi Daniel.

We suppose that it's not CLion problem, but problem with using CMake + MinGW, because they don't support non-latin symbols.
To solve the problem you can
1) change usage of MinGW to Cygwin
or
2) сhange idea.system.path in the IDE_HOME\bin\idea.properties file so it won't contain non-latin symbols (please see https://intellij-support.jetbrains.com/entries/23358108 and https://www.jetbrains.com/idea/help/project-and-ide-settings.html for more details).
Will it be suitable for you?
0

Please sign in to leave a comment.