Can I disable (annoying) tooltips "? <suggestion> Alt + Enter"?

Answered

NOTE: there is a solution in the comments

Hi,

First of all I'm really happy with the Jetbrains IDE's :). I have just one question.
Unfortunately I'm working with a big codebase that's not easily converted into a CMake project. And I don't have all the include files on my local machine. (This is an NFS mount from a remote server).
Anyway, I'm perfectly happy with using CLion. But this is driving me completely crazy:
Tooltip_017.png

Constantly this popup over my code. And I have to switch focus so it won't be displayed anymore. I can enable Power Save mode, but then I lose the ability to click on classes etc. Maybe I can't find the setting, is there one to disable it?

Thanks in advance,
Kind regards, Ray

8
24 comments
Official comment

For CLion the setting, similar to the one described above, is: File | Settings | Editor | General | Auto Import, C/C++, Show import popup.

Try right-clicking in the right edge of an editor, choosing "Customize Highlighting Level", and unchecking "Import popup".

I'm using IDEA UE 2017.2.6

2

The following seems to have worked for me:

1. Go to File -> Settings -> Editor -> General -> Auto Import

2. Untick "Show import popup for classes" and "static methods and fields"

3. Click OK

That's with IntelliJ IDEA 2017.1.2 Community Edition.

Note that b0b0b0b's solution (which gave me the clue) changes the setting on a per-file basis, whereas the above changes it throughout.

2

I am currently refactoring Java assertions from JUnit to Hamcrest.

When I remove the JUnit imports, the pop-ups will not stop! It severely interferes with my refactoring when I am constantly being bombarded by pop-ups telling me it can't find `assertTrue`, etc.

There should be a way to temporarily disable pop-ups in the editor window!

1

Thanks Renat, I managed to disable a few, but there are just too much, I would like it if there is a global setting to disable all of them. Some I also couldn't choose "disable".

I think I'm going to use Power Save Mode again, most of the stuff like navigate to file or symbol still works, so that's nice.

0

Ray,

in this case you can try to play with the code inspections. Open Settings (or Pereferences, if you are OS X user) dialog, choose Editor | Inspections.  On the Mange tab (right pane of the dialog) select Copy. Then click the C/C++ node. Here you can find the setion that is probably responsible for your tooltips and disable it. Or disable the whole C/C++, if you like. This way you have all the IDE features working and no tooltips at all. You can return back to Project Default inspections profile when you need it.

0

Thanks for your suggestions, I already tried that, actually I disabled them all, but I still get a lot of this stuff like "Cannot Resolve":

Selection_021.png
I can surpress them though:

Tooltip_019.png

I disabled all inspections, also for the default profile, and invalidate+rebuild my index + restart IDE. Still get stuff like above image unfortunately.
For now I'm going to use power mode again, but it would be really nice if in the future I can just disable all that suggestions, or perhaps choose a dedicated window for it or something :)

0

I am in the same boat. Disabling "code inspections" for C++ does not help. Do you have a solution for this annoying problem?

0

Hey,

I forgot about this to be honest. I'm using 2017.1.3 and still working on that same code base, but I don't have the annoying tooltips.

I'm not sure if I changed anything in my configuration to deal with the popups, but I have one theory.

 

Back in the day I had a CMakeLists.txt that would add *.cpp and stuff like that. Now I didn't bother to try that anymore.

Now all the files are not considered as part of the project, literally everything is greyed out in the Project tool window, but all the stuff I do use works perfectly.

 

0

I have the same problem, and I don't know what to do.

 

I prefer not suggesting anything until I press alt-enter. it is the most stupid thing about the whole IDE in my opinion

0

Is there no way to get rid of the obnoxious incessant popups without disabling all inspection?  What is the point of an IDE if it doesn't provide language specific information?  Might as well be using notepad.

0

How do I turn off the annoying blue suggestions???  I do NOT want any suggestions.  File/Settings/Editor/Inspections/C/C++ is all off.  What else turn these

... messages on?  please help. 

example:

?global variable 'data' from <something.h>? Alt+Enter

I don't want anything to pop up while I try to focus and write code!!!

 

0

Anna Falevskaya's answer fixed it for me.  Thank you.

0

Turning off inspections is an idiotic answer especially given that many of them are invisible until the mouse passes over and a popup is shoved in the user's face.  

I don't want a language unware editor.   You might as well say "use notepad."

 

0

This, amongst other issues and the non existing support, led me to the decision to look for another editior.

0

Hi, Kai! The answer for this issue is in the comment. What other problems have you encountered? Where have you reported them?

0

Kai, I'm in the same boat.  I recently used eclipse on a c/c++ project and the lack of the incessant popups was BLISS.  As much as I hate microsoft, I think I may be switching to visual studio for python.  I'm of the opinion that tooltips exist solely to help UI designers feel good about themselves.  Clearly intellij has a culture where making their UI designers feel good is more important than the user experience.

0

What popups do you get that you find annoying? Can't you fix the root cause of the popup?

My original question was about CLion which is kind of a different thing, there was no project file for the project I was working on.

Did you configure the right Python interpreter?

0

Update: although the steps in my previous comment seem to work, it breaks auto import on paste! I can only assume that this is a bug in IntelliJ, as popup settings should surely not affect auto import on paste!

0

I want to do the opposite by auto importing all suggestions without manually do alt + enter each time, what's the best way to do that?

0

I'm currently going through a merge with conflicts -- which leads to "method resolution" pop-ups getting in the way.  I, too, want a way to temporarily disable the pop-ups without resorting to disabling all inspections.  Sure, highlight the issues but don't throw up pop-ups that obscure what I need to change to make the merge possible.

0

As it's stated above, you can disable auto-import

in CLion in File | Settings | Editor | General | Auto Import > C/C++ > Show import popup,

in IntelliJ IDEA: https://www.jetbrains.com/help/idea/creating-and-optimizing-imports.html#disable-import-popups.

0

@Eugene Von, not sure it's technically possible since sometimes there are multiple import choices and you need to select the right one. Feel free to ask in the platform's tracker: https://youtrack.jetbrains.com/issues/IDEA

0

Ray,


Try to disable the respected intention action. Press Alt+Enter when you see the tooltip, select the action from the list and press the right arrow key. In the context menu, select "Disable".

Please, let me know the results.

-2

Please sign in to leave a comment.