Can't get MinGW-x64 working

I've tried to install several versions of MinGW-64 with no success.

First I tried to download from here:
http://sourceforge.net/projects/mingw-w64/

I tried the latest version.  CLion doesn't support 5.  It says on the Toolchain page that it supports up to 4.x.  So I install 4.9.3.  CLion says, when I point to that directory, that it's version 5.  First major road block.

So I did some searching and found that at one time, CLion did not support MinGW64.  From what I can tell, that was resolved a long time ago.
I do have the latest.

So I did some poking around and found the page https://www.jetbrains.com/clion/quickstart/ , which says "CLion supports GCC and Clang compilers. This means that on Windows you can select between MinGW(or MinGW-W64) and Cygwin tool sets."

So I followed the link http://mingw-w64.org/doku.php , went to Downloads, in the table they have a link to the first Sourceforge project that I mentioned above and Win-builds.  So I install Win-builds.  Whenever I go to the Toolchain dialog and select the directory I installed to and then the subdirectory /mingw, I get cc1.exe has stopped working three times and then cc1plus.exe has stopped working three times then back to cc1.exe has stopped working three times then cc1plus.exe three times, then one final cc1.exe has stopped working.
Everything is now checked except GDB: not found.
Click Ok and then I get hammered by program has stopped working.

When it's all said and done:

Error:The C compiler "c:/MinGW/bin/gcc.exe" is not able to compile a simple test program.
It fails with the following output:
Change Dir: C:/Users/James/.clion10/system/cmake/generated/ee8224ff/ee8224ff/__default__/CMakeFiles/CMakeTmp
Run Build Command:"c:/MinGW/bin/mingw32-make.exe" "cmTryCompileExec3859868051/fast"
c:/MinGW/bin/mingw32-make.exe -f CMakeFiles\cmTryCompileExec3859868051.dir\build.make CMakeFiles/cmTryCompileExec3859868051.dir/build
mingw32-make.exe[1]: Entering directory 'C:/Users/James/.clion10/system/cmake/generated/ee8224ff/ee8224ff/__default__/CMakeFiles/CMakeTmp'
"C:\Program Files (x86)\JetBrains\CLion 1.0.3\bin\cmake\bin\cmake.exe" -E cmake_progress_report C:\Users\James\.clion10\system\cmake\generated\ee8224ff\ee8224ff\__default__\CMakeFiles\CMakeTmp\CMakeFiles 1
Building C object CMakeFiles/cmTryCompileExec3859868051.dir/testCCompiler.c.obj
c:\MinGW\bin\gcc.exe -o CMakeFiles\cmTryCompileExec3859868051.dir\testCCompiler.c.obj -c C:\Users\James\.clion10\system\cmake\generated\ee8224ff\ee8224ff\__default__\CMakeFiles\CMakeTmp\testCCompiler.c
CMakeFiles\cmTryCompileExec3859868051.dir\build.make:56: recipe for target 'CMakeFiles/cmTryCompileExec3859868051.dir/testCCompiler.c.obj' failed
mingw32-make.exe[1]: *** [CMakeFiles/cmTryCompileExec3859868051.dir/testCCompiler.c.obj] Error 1
mingw32-make.exe[1]: Leaving directory 'C:/Users/James/.clion10/system/cmake/generated/ee8224ff/ee8224ff/__default__/CMakeFiles/CMakeTmp'
Makefile:116: recipe for target 'cmTryCompileExec3859868051/fast' failed
mingw32-make.exe: *** [cmTryCompileExec3859868051/fast] Error 2
CMake will not be able to correctly generate this project.

Several more errors like that with almost identical text.  With one caveat ... That's not the directory I selected.  c:/MinGW is an old version.  When I go back to the Toolchan editor, more errors.  Directory says c:\MinGw-64\mingw

HALP, please!

How did you install mingw?

2 comments
Comment actions Permalink

1.05 #CL141-875 built July 10, 2015 in case anyone's wondering.  They really should have a copy button on that about page. :)

0
Comment actions Permalink

Hi James.

Please make sure you don't have old mingw in your PATH.
Does that help?

0

Please sign in to leave a comment.