How can I build to my project directory?

I cannot figure out how to build to my project directory. This is what I see when I build:

"C:\Program Files (x86)\JetBrains\CLion 1.0.1\bin\cmake\bin\cmake.exe" --build C:\Users\my_name\.clion10\system\cmake\generated\b570c563\b570c563\Debug --target Featurizer -- -j 4
[100%] [100%] [100%] Building C object CMakeFiles/Featurizer.dir/getopt.c.obj
Building C object CMakeFiles/Featurizer.dir/jcstring.c.obj
Building C object CMakeFiles/Featurizer.dir/featurizer.c.obj
Linking C executable R:\projects\SESAME\featurizer\bin\Featurizer.exe
[100%] Built target Featurizer

Even though it says it is linking to the project directory, it is not; it is building to the default \Users directory, which it should not.

My txt file looks like this:

set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/lib)
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/lib)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/bin")

cmake_minimum_required(VERSION 3.1)

project(Featurizer)

set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")

add_executable(Featurizer featurizer.c jcstring.c jcstring.h getopt.h getopt.c)

I also tried setting the "build settings". No Effect. screenshot below:

build settings.png


1 comment
Comment actions Permalink

Hi John.

Sorry, you can't move your intermediate build directory anywhere (only by moving it for all projects by modifying idea.properties). But build artifacts (your .exe, for example) should be in the folder specified by "Build output path". Please confirm that you're actually don't have your .exe there (regardless of what presents in .clion10 folder).

0

Please sign in to leave a comment.