Support for high DPI displays?

I noticed this in an update for IntelliJ from February 2014:

Support  for Windows/Linux HiDPI devices via -Dis.hidpi=true - See more at:  http://blog.jetbrains.com/idea/2014/02/intellij-idea-13-1-early-preview-is-out/#sthash.i2piEeHn.dpuf
IntelliJ IDEA 13.1sf
IntelliJ IDEA 13.1In
IntelliJ IDEA 13.1
IntelliJ IDEA 13.1

* Support for Windows/Linux HiDPI devices via -Dis.hidpi=true

Does clion have a similar option? I haven't been able to get its icons and some other items to scale in Ubuntu. I could scale the text using a display option for Ubuntu, but that has no impact on icons.

3 comments
Comment actions Permalink

Hi Shaun.

If HiDPI support doesn't work on your Linux, please add -Dhidpi=true to your vmoptions file. Don't forget to remove old "is.hidpi" parameter if you have one.

If it doesn't work as expected, please add some comments to the issue.

0
Comment actions Permalink

That worked perfectly, thanks! The only very minor issue is that the 'Tip of the day' dialog has very tiny text in its content area (as well as any pictures in that area). The 'Did you know...?', 'Show TIps on Startup' and buttons are all the correct (large) size. But everything in the main IDE look perfect, including the icon size.

0
Comment actions Permalink

What about if your laptop has a 4K display but your external is 1080p?  I am on Fedora 25 and had it working where it would auto scale when it transferred monitors (like gnome terminal does)  Currently, I have to set the vmoptions hidpi to either true or false depending on which screen I want to work it.  Also, when I set hidip to true, the code portion is fine, but the tools and projects are all 2x ... when I bring it down to the 4K, everything looks good except the code, which is half the size it should be.  Using latest PhpStorm.

0

Please sign in to leave a comment.