"Unable to save exception ports" prevents debugging on Mac OS X 10.8.5

Taking CLion for a first test drive.
Using build CL-138.1965.18 (2014-09-08) on OS X 10.8.5 (Mountain Lion).
CLion build action appears to be using clang installed by Xcode (Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)).

Created simple "hello world" project (complete code shown below). Modified CMAKE_CXX_FLAGS in CMake Cache to "-std=c++11". No other customizations made.
Builds and runs ok without debugging.
When I try to debug it (i.e., ^D), it fails with the following message:

     /Users/curtis/Library/Caches/clion10/cmake/generated/d484047e/d484047e/Debug/HelloCLion
     Unable to save exception ports, task_get_exception_portsreturned: 4

     Process finished with exit code 0

Any suggestions?

--------

 
#include <iostream>
#include <vector>
using namespace std;

int main() {
    cout << "Hello, World!" << endl;
    int
y[] = {2, 3, 5, 7};
    vector
<int> x(y, y+4);
    for
(auto e : x)
        cout << ' ' << e;
    
cout << endl;
}
3 comments
Comment actions Permalink

Are you using bundled GDB? Or some custom one? Attach screenshot from Preferences | Build, Execution, Deployment | Toolchain.

0
Comment actions Permalink

Looks like it should be using the bundled gdb.

Screen Shot 2014-09-10 at 6.14.31 AM.png

0
Comment actions Permalink

Hi Curtis,

I've submited the issue (http://youtrack.jetbrains.com/issue/CPP-974) based on your description. As a workaround I would suggest you to install gdb from macports or homebrew and select it manualy (in Preferences->Toolcahains). BTW, make sure that you followed the instruction on signing gdb binary (https://sourceware.org/gdb/wiki/BuildingOnDarwin)

Best Regards,
Alexey

0

Please sign in to leave a comment.