Problem on Debian stable: embedded cmake and gdb depend on glibc >=2.14

Has anybody sorted this out?
I cannot move to testing, so I tried to just download the proper libc6{,-dev,-dbg} packages from testing and make them available to clion through LD_PRELOAD and/or LD_LIBRARY_PATH, but then I get

Inconsistency detected by ld.so: dl-close.c: 743: _dl_close: Assertion `map->l_init_called' failed!

when trying to use embedded gdb for example.

Any idea?

Thanks,
Andrea.

4 comments
Comment actions Permalink

It's true. You can't use previous glibc version with bundled cmake and gdb.
However you can specify the cmake and gdb you want (if it differ from the bundled one) in Preferences (Settings) | Build, Execution, Deployment | Toolchain.

0
Comment actions Permalink

Thanks for the reply,
I indeed already switched over to using local versions of cmake and gdb, although I preferred to keep using the embedded ones, but if the dependency on the newer glibc is mandatory I can live with that.
But then I've encountered another problem with gdb that causes an unsupported version error (I'm going from memory as I don't have the linux box accessible right now).
I suspect it is caused by debian's gdb reporting the version as "GNU gdb (GDB) 7.4.1-debian". In other words, could it be the "-debian" suffix to cause the version parsing to fail, or is it simply a newer (> 7.4.1) version required?

Andrea.

0
Comment actions Permalink

The supported GDB version is 7.8.

0
Comment actions Permalink

Ah, ok.
I'll try to upgrade to a newer gdb then.

Thanks,
Andrea

0

Please sign in to leave a comment.