PyCharm doesn't start. Says initial heap size larger then maximal heap size


I've got a problem. 

After miss clicking or clicking not wisely on VCS properties in PyCharm, the PyCharm stopped starting. I tried to start it from and i've got the following error:

2016-11-11 05:39:28.744 pycharm[457:6158] Value of PYCHARM_VM_OPTIONS is (null)
2016-11-11 05:39:28.744 pycharm[457:6158] Processing VMOptions file at        /Users/MVA/Library/Preferences/PyCharm2016.2/pycharm.vmoptions
2016-11-11 05:39:28.744 pycharm[457:6158] Done

Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size

I tried managing pycharm.vmoptions. There I have the following:


I found this very confusing. Xms - initial heap size. Xmx - maximal. I have no idea how to fix this and why this doesn't work.

I need your help, guys. 

Thanks, Vladislav


UPDATED!: My stupidness. I've been managing the wrong vmoptions file. vmoptions file, the file in .app/contents/bin is not being used. I don't know how to delete this embarrassment. 




Please sign in to leave a comment.