Out of Memory Error w/Webstorm 2016.3

Just installed the update this morning and right away, before I even begin trying to work with the IDE, Webstorm is showing me the Out of Memory dialog. I doubled the -Xmx to 1500 from 750, but haven't yet touched the other two fields, -XX:MaxPermSize and -XX:ReservedCodeCacheSize. Oddly, the value for -XX:MaxPermSize is shown as "Unknown".

I've seen OOM errors before, but never when I'd just opened projects and hadn't even begun working.

Is anyone else experiencing this? Is there a known fix?





Which folder it is? Because my log files are in the root. I am using Mac so in my user root Folder.


Or not. In my case looks like problem was in Symfony2 Plugin https://www.dropbox.com/s/bf0iv1sm6sweoic/idea.log?dl=0 
I disabled him and now don't see error for a while


Hi all,

I ran into the same problem today. Checking the logs revealed that there was some corruption in an index file so no amount of memory could solve the problem. I Invalidated the caches (File menu > Invalidate caches / Restart) and the problem disappeared.




I had a corrupted index a well and adding memory didn't work.  Invalidate caches fixed the problem.


had the same sort of problems today with PHPStorm 2017.2.4

whenever I tried to change the editor font size I got this out of memory message

tried to think what changes I made (new PC), uninstalled the mongodb plugin, now seems that things work fine (although can't blame the thing in 100% of course)


Please sign in to leave a comment.