Custom Plugin no longer works

Answered

I recently tried to run a plugin that was working in Intellij 15, but now does not seem to run in 16.

This plugin depends on com.jetbrains.php, and for some reason there is weirdness with the classes at some low level.

Here's an error that illustrates my problem:

java.lang.ClassCastException: com.jetbrains.php.lang.psi.elements.impl.MethodImpl cannot be cast to com.jetbrains.php.lang.psi.elements.impl.MethodImpl

Here's the dependencies section of my plugin.xml:

<depends>com.jetbrains.php</depends>
<depends>com.intellij.modules.platform</depends>


and my plugin module depends on:

<my home directory>/Library/Application Support/IntelliJIdea2016.2/php/lib/php-openapi.jar
<my home directory>/Library/Application Support/IntelliJIdea2016.2/php/lib/php.jar

Module SDK is Intellij IDEA IU-162.2228.15 (java version "1.8.0_92")


 

1 comment
Comment actions Permalink

Actually I was able to resolve this, I had included the php jars in the compile scope.  Once I changed the scope to provided everything worked fine.

 

 

0

Please sign in to leave a comment.