Debug webstorm not provided

I tried to debug my javascript but the tools to step into code does not enabled: enter image description here

And on chrome browser I installed jetbrains extension: enter image description here

What am I doing wrong?

 

Thanks

12 comments

Stepping is only available when execution is suspended on breakpoint. From your screenshot it seems that breakpoint is not hit. Are you debugging server (Node.js) or client code? Seems the debug session is started for client side, but code looks like the server-side one... Sample project that shows up the issue would be helpful

0

I debug it on the client side. Now it works as expected:

0

It is so odd, sometimes works sometimes not. 

As you can see above, I set the break point on callback. Is that the reason, why I can not step in.

0

works fine for me - see screenshot.

My steps:

- added breakpoint to line 39 in index.html

- right-click index.html, choose Debug

0

Once breakpoint is hit, I can step in/over until application fails because of missing resource

0

I did as you told me above:

Browser get started:

And I can not step into:

Is the browser the problem?

Thanks

 

0

Noi idea. Please record a screencast that shows up the issue

0

Breakpoint is not hit, because the corresponding line is not executed - application fails before getting to it because of a problem getting https://openui5.hana.ondemand.com/resources/sap/ui/thirdparty/sinon.js: GET request fails

0

You test it and it works on your computer?

0

It works for me if I set built-in server port (Settings | Build, Execution, Deployment | Debugger, Port) to some non-default value (12345, for example). When I access the app using http://localhost:12345/webapp/index.html then, HTTP request is sent properly; but, when serving application using default port (63342), I get `NetworkError: Failed to execute 'send' on 'XMLHttpRequest': Failed to load 'https://openui5.hana.ondemand.com/resources/sap/ui/thirdparty/sinon.js'.`

Error is not very verbose, looks as if the request is blocked for some reason

0

Please sign in to leave a comment.