Cannot connect via SSH, but I can do so with Sequel Pro

Hi, I'm not sure if this is a bug or if I'm doing something wrong. I'm trying to connect to MySQL via SSH, as usual. When I do this in Sequel Pro with the same settings, it works fine.

I can definitely SSH to the server, which is a Digital Ocean droplet. From the shell, I can get into MySQL and run queries as normal. I enter the usual settings in Sequel Pro, and it works. If I do it in 0xDBE I get an authentication error (USERAUTH FAIL).

I'm attaching my config screens from 0xDBE and a comparison one from Sequel Pro.

How can I debug this? Is 0xDBE using some custom ssh process or something?



Attachment(s):
sequel_pro_2014-09-22_12-43-23.png
0xdb_2_2014-09-22_12-40-31.png
0xdb_1_2014-09-22_12-40-18.png
12 comments
Comment actions Permalink

Same problem here, The 0xDBE is unusable if lack for this feature.

0
Comment actions Permalink

USERAUTH FAIL sounds like it's an issue with the java class that JetBrains uses for SSH Authentication.

Can you generate a new public/private key-pair and attempt to use that instead?

Are you able to use any other JetBrains product and connect to that server (SFTP) with that key?

0
Comment actions Permalink

I did with no luck.
Actually, I used the same key to connect same server with PhpStorm 8 before.

0
Comment actions Permalink

I'm having the exact same problem. I have used the same settings in MySQL workbench and it works fine. When using these settings in 0xDBE I get the "SSH: USERAUTH fail" message.

A solution to this issue would be greatly appreciated.

0
Comment actions Permalink

Did anyone find a solutuon for this?

0xDBE had been working fine by yesterday my MySQL connections which use SSH started getting the         SSH: Auth fail error. And i can also connect with Sequel Pro using the same settings.

0
Comment actions Permalink

Could you please check the last EAP build from https://www.jetbrains.com/dbe/download/ . There were fixes for SSH-tunneled connection.

0
Comment actions Permalink

I'm trying this with DataGrip 1.0.1 (Dec 25, 2015 build) on MacOS X, and also having trouble. When I do Test Connection, I get "SSH: Algorithm negotiation fail". Same settings I use with a different DB GUI tool. Is there any way to see the full log of error info from DataGrip for this? I don't see it in the log file that's on disk. Product is essentially useless to me without this.

0
Comment actions Permalink

Hello,
This kind of exception usually happens when sets of algorithms available on server and client do not intersect (more background information on SO discussion: http://stackoverflow.com/questions/26424621/algorithm-negotiation-fail-ssh-in-jenkins ).

What JDK do you use run run DataGrip (seen in about dialog)?  Do you have this problem with MySQL server?

Sometimes installation of extended JCE helps, see https://youtrack.jetbrains.com/issue/WI-25360#comment=27-831637 .

If problem remains, please attach idea.log https://intellij-support.jetbrains.com/hc/en-us/articles/207241085 after IDE restart and reproducing the error. Thanks.

0
Comment actions Permalink

I'm using JRE 1.8 and the OpenJDK according to the About box. I just installed Java 8 from Oracle, but I'm not seeing how I can tell the IDE to boot with this (the Find Action dialog for DataGrip doesn't offer that switching option like IntelliJ does (per blog post)).

0
Comment actions Permalink

Please attach idea.log after IDE restart and reproducing the error.

0
Comment actions Permalink

I'm linking to the log below. I deleted the log, then started DataGrip, reproduced the failure a couple times, then shut it down. This is the full log. I'm wondering if I need to adjust the log level or something, as I don't see any of the SSH errors in the log.

https://gist.github.com/chris/4a26c9c00b45c3676faf

0
Comment actions Permalink

Thank you,

Created the https://youtrack.jetbrains.com/issue/DBE-2179 for this issue. Please follow it for updates (please see https://intellij-support.jetbrains.com/hc/en-us/articles/207241135 if you are not familiar with YouTrack).

0

Post is closed for comments.