Java 6 Required for La Clojure?

I'm having trouble starting up IntelliJ with the clojure plugin installed.  I get errors like:


------------------------------------------------------
2009-06-07 00:22:01,345 [   7569]  ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.idea.MainImpl$3@24fb16,notifier=null,catchExceptions=false,when=1244348520700] on apple.awt.CToolkit@e07360
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
at java.lang.ClassLoader.defineClass(ClassLoader.java:520)
at com.intellij.util.lang.UrlClassLoader._defineClass(UrlClassLoader.java:119)
at com.intellij.util.lang.UrlClassLoader.defineClass(UrlClassLoader.java:115)
at com.intellij.util.lang.UrlClassLoader._findClass(UrlClassLoader.java:91)
at com.intellij.ide.plugins.cl.PluginClassLoader.loadClassInsideSelf(PluginClassLoader.java:78)
at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:41)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:374)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:242)
at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.loadClass(ExtensionComponentAdapter.java:140)
at com.intellij.openapi.extensions.impl.ExtensionComponentAdapter.getComponentImplementation(ExtensionComponentAdapter.java:61)




This looks to be an issue loading code compiled in a different JDK source.  When I uninstall La Clojure, IntellIJ starts up fine.  Upgrading to Java 6 isn't an option for me (running a 32-bit Mac).  Is Java 6 really required for La Clojure or can it be compiled to 1.5?



3 comments

I did try to use SoyLatte/OpenJDK to get Java 6 support for 32-bit Mac, but IntelliJ can't find the core java classes:

http://www.jetbrains.net/jira/browse/IDEA-22607

0

Hello, Adam.

I use La Clpojure with JDK 1.5 on my mac since it's compiled for Java 1.5. What version of plugin do you use?

With best regards,
Ilya

0

Please sign in to leave a comment.