Error while importing SBT project

Hi,


I installed IDEA15.0.1+scala plugins on windows 7. When I tried to begin a new Scala project "HelloScala" with SBT, there was always an error arising-----
Error while importing SBT project:  https://repo1.maven.org/maven2/org/scala-sbt/sbt/0.13.7/sbt-0.13.7.jar

    UNRESOLVED DEPENDENCIES :: org.scala-sbt#sbt;0.13.7: not found
:: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
unresolved dependency: org.scala-sbt#sbt;0.13.7: not found
Error during sbt execution: Error retrieving required libraries

--------------------------------------------------------------------------------
I tried the above URL in IE11 and the result was "404 not found" indeed.

You know I am a freshman for Scala and IDEA. The problem had been persistent for 24 hours. So How can I solve it?

Thanks a lot!!!

regards,
Pippon

6 comments
Comment actions Permalink

Could anybody help me???

0
Comment actions Permalink

Could you please post here complete SBT log? You can find it by clicking on "Help -> Show log in File Manager" menu item and then opening 'sbt.last.log' file

0
Comment actions Permalink

com.intellij.openapi.externalSystem.model.ExternalSystemException: Error while importing SBT project:<br/><pre>Invalid initial heap size: -Xms1g -Xmx2g -XX:PermSize=512m -XX:MaxPermSize=1g
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

0
Comment actions Permalink

Please check IDEA settings / Build tools / SBT / Maximum heap size & VM parameters settings and SBT_OPTS environment variable.

2 GB heap is probably too much, and definitely too much for 32 bit JVM.

0
Comment actions Permalink

Thanks Pavel, however I have 64bit JVM and overall I'm using 4g for some apps often.

0
Comment actions Permalink

Then make sure that SBT is launched in the correct JVM - Build tools / JVM (project JVM by default). For initial project import those settings are under "SBT global options" in the project import wizard.

You may try to set JVM there explicitly. Also, please try lower all the memory-related settings to see whether that helps.

0

Please sign in to leave a comment.