Importing SBT project fails with custom user folder on Windows 7

Hey,

I ran into a problem when trying to use the scala plugin. When I want to import or create a SBT project it fails with a FileNotFoundException for the update.log file. The plugin looks for the file under C:\Users\<username>\.sbt\boot\update.log which does nto exist as I moved my user folder to another partition, so it should look under D:\User...

I figured I should be able to override that path by setting sbt.boot.directory parameter but so far I had no luck setting it. I tried %SBT_HOME%\sbt\config\sbtconfig.txt, %SBT_HOME%\sbt\config\sbtopts (though that should only be relevant for Linux systems), <IDEA HOME>\bin\idea.properties, <IDEA HOME>\bin\idea.exe.vmoptions, <IDEA HOME>\bin\idea64.exe.vmoptions and I set it in the IntellJ preferences for the sbt plugin. But nothing changes the error message, so I am quite stumped right now.

Has anyone an idea what I can do to pass the property to the plugin? Running sbt from command line works just fine.I also reinstalled the current sbt version 0.13.8.

Thanks,
Chris

2 comments
Comment actions Permalink

Hi! Could you please tell me how exactly did you move user folder? I used http://docs-windows.readthedocs.org/en/latest/move-users-to-another-drive.html and could not reproduce your problem.

0
Comment actions Permalink

TBH I cannot find the guide I used anymore but it was definitly different from the one you used and more complicated. It seems I somehow used a broken guide as most others I just found looked very much like yours.

As it worked with that guide and my way broke some other tools as well that I had to reinstall this does not seem like a problem on your side. There is probably something screwed up in my settings now that gives IntellJ the wrong drive to look in.

0

Please sign in to leave a comment.