JetGroovy plugin does not work

I have a Java project, and have installed this plugin. It says that the version is 8.0.
I have IDEA 1.8.3

I have installed Groovy on an external directory. Then I created the Groovy facet for my module, enabling auto-detection. The Groovy libraries show as Global Libraries.

So I have the plugin and the Groovy facets, but when I create a .groovy file, it does not recognize it as Groovy, so I cannot compile, etc.
Also, when I create a file, the menu does not show an option for a Groovy file.

After my settings I restarted IDEA.

What did I do wrong?  Is the plugin version wrong?

Any help I will appreciate.

Thanks,

Gisella

4 comments
Comment actions Permalink

Hello Gisella,

You do not need to install the Groovy plugin separately, because it's bundled
with IntelliJ IDEA.

Please make sure that the .groovy extension is assigned to the Groovy file
type in Settings | File Types.

I have a Java project, and have installed this plugin. It says that
the version is 8.0. I have IDEA 1.8.3

I have installed Groovy on an external directory. Then I created the
Groovy facet for my module, enabling auto-detection. The Groovy
libraries show as Global Libraries.

So I have the plugin and the Groovy facets, but when I create a
.groovy file, it does not recognize it as Groovy, so I cannot compile,
etc.

Also, when I create a file, the menu does not show an option for a
Groovy file.

After my settings I restarted IDEA.

What did I do wrong?  Is the plugin version wrong?

Any help I will appreciate.

Thanks,

Gisella

---
Original message URL:
http://www.jetbrains.net/devnet/message/5248983#5248983

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I have a similar issue with 9.0 release

I had a groovy facet enabled in my fairly large project.

Groovy files are no longer recognized and the the settings filetypes does not offer groovy as a file type with which to associate the .groovy extension.

Also, the select technologies screen does not include groovy as a technology option, though the online help suggests that is should be there

Groovy 1.6 is included in my dependencies

History:
Before dowloading 9.0 I had downloaded the beta, but then returned to using 8.1.4 after creating a single test project with the 9.0 beta

-Charles

0
Comment actions Permalink

Hello charles,

Looks like you have disabled the Groovy plugin. Please enable it in Settings
| Plugins.

I have a similar issue with 9.0 release

I had a groovy facet enabled in my fairly large project.

Groovy files are no longer recognized and the the settings filetypes
does not offer groovy as a file type with which to associate the
.groovy extension.

Also, the select technologies screen does not include groovy as a
technology option, though the online help suggests that is should be
there

Groovy 1.6 is included in my dependencies

History:
Before dowloading 9.0 I had downloaded the beta, but then returned to
using 8.1.4 after creating a single test project with the 9.0 beta
-Charles

---
Original message URL:
http://www.jetbrains.net/devnet/message/5252677#5252677

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

You are right.
The plugin was disabled, though I have no idea why it was disabled.
It was enabled before the upgrade.
Perhaps I accidently disabled it when going through all of plugin options during the upgrade, meaning to disable something else.

In any case, thanks

-Charles

0

Please sign in to leave a comment.