Play 2 support gone in Scala plugin 1.5?

I've upgraded the scala plugin to 1.5 (running IDEA 14.1.3) and all play 2 support seems to have disappeared. IDEA is compiling with the scala compiler, I have no highlighting or formatting in routes files and no autocomplete in templates. Any ideas what might be going on?

9 comments
Comment actions Permalink

Please check that you use IntelliJ IDEA Ultimate Edition.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Yes, I use Ultimate. The 1.4 plugin was working fine.

0
Comment actions Permalink

Please try to remove ".idea" directory and then import SBT project again. To check if it's migration problem or something even worse.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

There is basically no Preferences -> Languages & Frameworks -> Play2 section in my preferences

0
Comment actions Permalink

Seems to be something worse, I'm afraid. Cleared out all the .idea and target directories and re-imported and just the same :-(

0
Comment actions Permalink

Hello,

was the project imported properly? I.e. is there red code caused by absent libraries etc? And is there play2_project_settings.xml under /.idea?

0
Comment actions Permalink

The project has imported correctly. If I compile the templates and other resources from the activator command line then any changes I make to the scala recompile fine in IDEA.

Have you seen my other comment? Bascially "There is no Preferences -> Languages & Frameworks -> Play2 section in my preferences"

0
Comment actions Permalink

Do you have JavaScript plugin enabled? Play2 support depends on it now

0
Comment actions Permalink

I didn't have JavaScript Support enabled. I've done so now and that's fixed it. Looks like it could do with a warning on upgrade :-)

0

Please sign in to leave a comment.