JDK 6 Only?

Downloaded the latest 0xDBE, fired it up, and it says 'To open "0xDBE," you need a Java SE 6 runtime. Would you like to install one now?'. I have JDK7 installed, does 0xDBE deliberately exclude that? I don't really want to install Java SE 6 just for 0xDBE. I didn't see any previous posts talking about this, so I figured I'd ask.

4 comments
Comment actions Permalink

I'm able to run 0xDBE with Java 7, but I also have the JRE installed separately (instead of using the packaged JRE with the JDK). You may be able to get away with adding the jdk7/jre/bin folder to your system PATH



Attachment(s):
0xdbe_about.png
0
Comment actions Permalink

As a follow-up to my previous post, you may also want to point to your JDK through the xDBE_JDK environment variable (e.g. Mine is pointing to C:\glassfish4\jdk7)

0
Comment actions Permalink

FWIW, without having attempted anything new with the latest EAP build:
Screen Shot 2014-09-17 at 4.32.58 PM.png
It could be this, in 0xDBE.app/Contents/Info.plist:

   <key>JVMOptions</key>     <dict>       <key>ClassPath</key>       <string>$APP_PACKAGE/Contents/lib/bootstrap.jar:$APP_PACKAGE/Contents/lib/extensions.jar:$APP_PACKAGE/Contents/lib/util.jar:$APP_PACKAGE/Contents/lib/jdom.jar:$APP_PACKAGE/Contents/lib/log4j.jar:$APP_PACKAGE/Contents/lib/trove4j.jar:$APP_PACKAGE/Contents/lib/jna.jar</string>       <key>JVMVersion</key>       <string>1.6*</string>


Yeah, that's it. The Apple docs even recommend against using specifiers with "*" for exactly this reason. I changed it to "1.6+" and it loads now. Guess there weren't a lot of Mac users trying the EAP?

0
Comment actions Permalink

Anything other then JDK6 will force OSX to use the discrete GPU. For that reason alone I only use JDK6 on OSX. That said, there are also supposed to still be some graphical issues with JDK7+ on OSX that keep JetBrains from recommending them.

0

Please sign in to leave a comment.