Idea 14.0.2 create new scala project

I have fresh installation of IDEA 14.0.2, OS Windows 7 x64. Setting was imported from idea 12 and previuos installation was removed.

I installed Scala plugin http://confluence.jetbrains.com/display/SCA/Scala+Plugin+for+IntelliJ+IDEA version 1.2.1.
I am behind proxy. The 'Auto-detect proxy settings' is enabled. Checking connection from System Settings -> HTTP Proxy says everything fine.
When I am trying to create new Scala SBT project it requests credentials for proxy (it shows only local IP address that I know is the Forefront TMG proxy). If I would input credentials or click 'Cancel' it hangs infinitely. How I suppose to fix this issue?

6 comments
Comment actions Permalink

Actually, using sniffer I can see that some application (sbt-launcher ?) sends HTTP GET http://repo.typesafe.com/typesafe/ivy-releases/org.scala-sbt/launcher/ and proxy responds 407

0
Comment actions Permalink

Hi! Thanks for the report. Could you please add Java VM proxy flags (-Dhttp.proxyHost, -Dhttp.proxyPort, -Dhttp.proxyUser, -Dhttp.proxyPassword) with corresponding values into "VM Parameters" field in "Settings / Build, Execution / Build Tools / SBT" dialog and try to create new SBT project again? Will it work?

0
Comment actions Permalink

I added settings you mentioned, tryed both bundled and custom launcher and it worked for imported module with existed .sbt configuration. Creating new project still receives HTTP 407 from proxy.

If sbt launched from command line and JAVA_OPTS contained proxy settings everything is fine.

0
Comment actions Permalink

Good, thank you. I'd like to ask you one more detail: on what step of project creation does it hangs? Just right after you've selected "SBT" project and pressed "Next" or later?

0
Comment actions Permalink

It hangs after pressing "Next". Sometimes it shows a pop-up window and asks input proxy credentials, but after it hangs anyway.

0
Comment actions Permalink

Fixed it. Hopefully it will be shipped in next EAP build.

0

Please sign in to leave a comment.